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GWD Calculator
GWD Calculator is scientific calculator which can evaluate and plot expressions, solve 
equations, perform numerical integration and symbolical derivation.



GWD Font Editor
GWD Font Editor is bitmap font editor for Windows. You can edit many different types of 
fonts and export them in another format or font file.
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What is Shareware?
Shareware distribution gives users a chance to try softwarebefore buying it. If you try a 
Shareware program and continueusing it, you are expected to register. Individual programs 
differ on details -- some request registration while othersrequire it, some specify a 
maximum trial period. With registration, you get anything from the simple right to 
continueusing the software to an updated program with printed manual.
Copyright laws apply to both Shareware and commercial software, and the copyright holder
retains all rights, with a few specific exceptions as stated below. Shareware authors are 
accomplished programmers, just like commercial authors, and the programs are of 
comparable quality. (In both cases, there are good programs and bad ones!) The main 
difference is in the method of distribution. The author specifically grants the right to copy 
and distribute the software, either to all and sundry or to a specific group. For example, 
some authors require written permission before a commercial disk vendor may copy their 
Shareware.
Shareware is a distribution method, not a type of software. You should find software that 
suits your needs and pocketbook, whether it's commercial or Shareware. The Shareware 
system makes fitting your needs easier, because you can try before you buy. And because 
the overhead is low, prices are low also. Shareware has the ultimate money-back guarantee
-- if you don't use the product, you don't pay for it.



DISCLAIMER - AGREEMENT

Users of GWD Text Editor must accept this disclaimer of warranty: "GWD Text Editor is 
supplied as is. The author disclaims all warranties, expressed or implied, including, without 
limitation, the warranties of merchantability and of fitness for any purpose. The author 
assumes no liability for damages, direct or conse - quential, which may result from the use 
of GWD Text Editor."
GWD Text Editor is a "shareware program" and is provided at no charge to the user for 
evaluation.    Feel free to share it with your friends, but please do not give it away altered or
as part of another system.    The essence of "user-supported" software is to provide 
personal computer users with quality software without high prices, and yet to provide 
incentive for programmers to continue to develop new products.    If you find this program 
useful and find that you are using GWD Text Editor and continue to use GWD Text Editor 
after a reasonable trial period, you must make a registration payment of $20 to Author.    
The $20 registration fee will license one copy for use on any one computer at any one time.
You must treat this software just like a book.    An example is that this software may be used
by any number of people and may be freely moved from one computer location to another, 
so long as there is no possibility of it being used at one location while it's being used at 
another. Just as a book cannot be read by two different persons at the same time.
Commercial users of GWD Text Editor must register and pay for their copies of GWD Text 
Editor within 30 days of first use or their license is withdrawn. Site-License arrangements 
may be made by contacting author.
You are encouraged to pass a copy of GWD Text Editor along to your friends for evaluation. 
Please encourage them to register their copy if they find that they can use it.    All 
registered users will receive a copy of the latest version of the GWD Text Editor.



Macros
A macro is a custom-made command that helps you work more quickly and efficiently. 
Typically, a macro is a series of GWD Text Editor commands and actions that GWD Text 
Editor triggers when you run the macro.
Creating a macro is easy with the Record Macro command. GWD Text Editor records the 
actions you perform so you can play them back as a macro.
See also

Syntax
Predefined commands
Examples



Macro Syntax
The syntax to define a macro is:

<Command> [Parameters]
<Command>

Here are the rules for macro definition: 
1. Only one command per line is allowed.
2. A line starting with // or ; (semicolon) is treated as a comment and is ignored. Comments 

must appear on their own line.
3 Blank lines are ignored
4. If command parameter is an string, you can use C/C++ escapes to insert special 

characters:
\a Alert (ASCII 7)
\b Backspace (ASCII 8)
\f Formfeeds
\n New line (ASCII 10)
\r Carriage return (ASCII 13)
\t Horizontal tab (ASCII 9)
\v Vertical tab
\' Single quotation mark
\" Double quotation mark
\\ Backslash
\? Question mark
\000 ASCII character in octal notation
\xhh ASCII character in hexadecimal notation



Predefined Commands

Command Action
Backspace Deletes the character to the left of the cursor
BackTab Moves to previous tab position
BottomOfWindow Moves to the bottom of the text window
BottomOfWindowSelect Extends the selection to the bottom of the text window
CapitalizeWord Makes the first character in word uppercase.
CenterBlockPara Centers all lines in the selected text or current paragraph
CenterLine Centers the current cursor line
CommpresSpacesToTabs Compresses occurrences of multiple spaces to tabs
ConvertText Convert text
Copy Copies the selected text and puts in on the Clipboard
CopyAndAppend Copies the selected text and puts in to the end of Clipboard
CursorDown Moves the cursor one line down
CursorLeft Moves the cursor one character to the left
CursorRight Moves the cursor one character to the right
CursorUp Moves the cursor one line up
Cut Cuts the selected text and puts in on the Clipboard
CutAndAppend Cuts the selected text and puts in to the end of Clipboard
CutLine Deletes the selected lines and puts them on the Clipboard
Delete Deletes the selection or the character to the right of the cursor
DeleteBlock Deletes the selection
DeleteChar Deletes the character to the right of the cursor
DeleteLine Deletes the current line
DeleteToBOL Deletes from begin of line to the cursor
DeleteToEOL Deletes from the cursor to end of line
DeleteWord Deletes a word to the right
DeleteWordBack Deletes a word to the left
DownSelect Extends the selection down one line
DuplicateLine Duplicates the current line
EndLineDraw Finish line drawing
EndSelect Finish marking a block of text
ExpandTabsToSpaces Expands tab characters to the appropriate number of spaces
FillBlock Fills the selected column block with a pattern of characters
Find Finds the specified text
FindNext Repeats last Find or Replace operation
FindNextWord Finds the next occurrence of the selected text or the current 

word
FindPrevWord Finds the previous occurence of the selected text or the current



word
FirstNonBlank Moves to first non-blank character on the current line
FlipCase Flips the case of the current character or the selected text
FlipCaseWord Flips the case in word
GoToColumn Moves cursor to a specific column
GoToLine Moves cursor to a specific line
GotoMark0 Moves to bookmark 0
GotoMark1 Moves to bookmark 1
GotoMark2 Moves to bookmark 2
GotoMark3 Moves to bookmark 3
GotoMark4 Moves to bookmark 4
GotoMark5 Moves to bookmark 5
GotoMark6 Moves to bookmark 6
GotoMark7 Moves to bookmark 7
GotoMark8 Moves to bookmark 8
GotoMark9 Moves to bookmark 9
HelpKeywordSearch Displays help about the word at current cursor (insertion point)

location
HideSelect Stop highlighting the selected text
IndentBlock Inserts a space at the beginning of each line in the selected 

text
InsertChar Inserts the character at the current caret location
InsertComment Inserts C/C++    comment bars /***    ***/
InsertCommentLight Inserts light C/C++    comment bars /*--- ---*/
InsertDate Inserts current date at the current cursor position
InsertLine Inserts a new line
InsertSymbol Inserts a special character
InsertTime Inserts current time at the current cursor position
InsertTimeDate Inserts the current date and time
JoinLine Joins the line below the cursor line to the end of the cursor line
JustifyBlockPara Aligns the paragraph or selected block at both the left and the 

right indent
LeftBlockPara Deletes all leading spaces from the beginning of each line in 

the selected text or current paragraph
LeftSelect Extends the selection one character to the left
LineDrawStyle Selects line draw style
LineEnd Moves to the end of the current line
LineEndSelect Extends the selection to the end of the current line
LineStart Moves to the start of the current line
LineStartSelect Extends the selection to the start of the current line
LowerCase Converts the selected text or current character to lowercase
LowerCaseWord Makes the word lowercase
MacroStopRecorder Finishes recording actions



MatchPair Moves cursor to a matching brace character {([/* */])}
MatchPreprocNext Finds the next matching preprocessor condition (#if #else 

#endif)\nMatchPreprocNext
MatchPreprocPrev Finds the previous matching preprocessor condition (#if #else 

#endif)\nMatchPreprocNext
NewFile Creates a new file in new edit window
NewLine Inserts a new line with a carriage return
NullCmd No operation. Calls the editor, but performs no function.
OpenFile Opens an existing file
OpenFileAtCursor Opens the file at the cursor position
PageDown Moves the cursor down by one window
PageDownSelect Extends the selection down one page
PageUp Moves the cursor up by one window
PageUpSelect Extends the selection up one page
ParaDown Moves to the beginning of the next paragraph.
ParaDownSelect Extends the selection to the beginning of the next paragraph
ParaUp Moves to the beginning of the previous paragraph
ParaUpSelect Extends the selection to the beginning of the previous 

paragraph
Paste Inserts text from the Clipboard at the cursor position (insertion 

point)
Print Prints the contents of the active window
ReadBlock Inserts a file at position of the caret (insertion point)
RecordMacro Records the actions as a macro
Redo Redo the last undone editor action
Replace Finds the specified text and replaces it with a new text
RightBlockPara Right aligns all lines in the selected text or current paragraph
RightSelect Extends the selection one character to the right
SaveFile Saves the file in the active window
SaveFileAs Saves the file in the active window with a new name
ScrollDown Scrolls the file contents down one line
ScrollUp Scrolls the file contents up one line
SelectAll Selects all of    the text in the active window
SelectAll Selects the entire document
SelectLine Selects current line
SelectPara Selects the current paragraph
SelectWord Selects word
SentenceCase Capitalizes the first letter of the first word in the selected 

sentences
SetAutoIndent Sets the Auto Indent option On
SetAutoUnindent Sets the Backspace Unindents option On
SetCharSelMode Sets character (stream) selection mode
SetColumnSelMode Sets column (block) selection mode



SetInsert Sets Insert/Overwrite option to Insert
SetMark0 Drops bookmark 0
SetMark1 Drops bookmark 1
SetMark2 Drops bookmark 2
SetMark3 Drops bookmark 3
SetMark4 Drops bookmark 4
SetMark5 Drops bookmark 5
SetMark6 Drops bookmark 6
SetMark7 Drops bookmark 7
SetMark8 Drops bookmark 8
SetMark9 Drops bookmark 9
SetWordWrap Sets the Word Wrap option On
Sort Rearranges the selected text according to the a specified order
StartLineDraw Starts line drawing
StartSelect Starts marking a block of text
Tab Inserts a tab
TextEnd Moves to the end of the file
TextEndSelect Extends the selection to the end of the file
TextStart Moves to the beginning of the file
TextStartSelect Extends the selection to the beginning of the file
TitleCase Capitalizes the first letter of each word in the selection
ToggleAutoIndent Toggles the state of the Auto Indent option
ToggleAutoUnindent Toggles the state of the Backspace Unindents option
ToggleInsert Toggles the state of Insert/Overwrite option
ToggleLineDraw Toggles line drawing mode
ToggleWordWrap Toggles word wrap on/off
TopOfWindow Moves to the top of the text window
TopOfWindowSelect Extends the selection to the top of the text window
TransposeChar Swap characters around the insertion point (cursor)
TransposeLine Swap lines around the insertion point (cursor)
TransposeWord Swap words around the insertion point (cursor)
Undo Undoes the last editor actions
UnindentBlock Deletes a leading space, if any, from the beginning of each line

in the selected text
UpperCase Converts the selected text or current character to uppercase
UpperCaseWord Makes the word uppercase
UpSelect Extends the selection up one line
UserTool1 Activates user-defined tool 1
UserTool2 Activates user-defined tool 2
UserTool3 Activates user-defined tool 3
UserTool4 Activates user-defined tool 4
UserTool5 Activates user-defined tool 5



UserTool6 Activates user-defined tool 6
UserTool7 Activates user-defined tool 7
UserTool8 Activates user-defined tool 8
UserTool9 Activates user-defined tool 9
WordCount Displays the word statistics of the active document
WordLeft Moves back one word
WordLeftSelect Extends the selection forward one word
WordRight Moves forward one word
WordRightSelect Extends the selection back one word
WriteBlock Saves the selected text in active window with a new name



Macro Examples

C/C++ Comment a function
C/C++ if else
C/C++ while
C/C++ switch case
C++ class
PASCAL if else



Comment a function
USE: Put the cursor over function name which is at the left of the screen. Do not include 

the return type or parameters before using this macro.

// MACRO BEGIN
LineStart
NewLine
DupLine
CursorUp
CenterLine
LineEnd
NewLine
LineStart
CursorUp
CursorUp
InsertText 
"/**********************************************************************"
InsertText "***"
CursorDown
LineEnd
NewLine
NewLine
LineStart
InsertText "DESCRIPTION:"
NewLine
LineStart
InsertText "PARAMETERS:"
NewLine
InsertText "RETURN:"
NewLine
LineStart
InsertText 
"***********************************************************************"
InsertText "**/"
CursorDown
CursorDown
LineEnd
// MACRO END



C/C++ if else
InsertText "if() {"
InsertLine
WordLeft
CursorDown
InsertText "}"
InsertLine
CursorLeft
CursorDown
InsertText "else {"
InsertLine
WordLeft
CursorDown
InsertText "}"
CursorUp
CursorUp
CursorUp
CursorRight
CursorRight



C/C++ while
InsertText "while() {"
InsertLine
WordLeft
CursorDown
InsertText "}"
CursorUp
CursorRight
CursorRight
CursorRight
CursorRight
CursorRight



C/C++ switch case
InsertText "switch() {"
InsertLine
CursorLeft
WordLeft
CursorDown
CursorRight
CursorRight
InsertText "case:"
InsertLine
WordLeft
CursorDown
InsertText "case:"
InsertLine
WordLeft
CursorDown
InsertText "default:"
InsertLine
WordLeft
CursorDown
CursorLeft
CursorLeft
CursorLeft
InsertText "}"
CursorUp
CursorUp
CursorUp
CursorUp
CursorUp
CursorRight
CursorRight
CursorRight
CursorRight
CursorRight
CursorRight



C++ class
InsertText "class"
InsertLine
WordLeft
CursorDown
InsertText "{"
InsertLine
CursorDown
CursorRight
InsertText "private:"
InsertLine
WordLeft
CursorDown
InsertText "protected:"
InsertLine
WordLeft
CursorDown
InsertText "public:"
InsertLine
WordLeft
CursorDown
CursorLeft
CursorLeft
InsertText "};"



PASCAL if else
InsertText "IF THEN BEGIN"
InsertLine
WordLeft
WordLeft
WordLeft
CursorDown
InsertText "ELSE BEGIN"
InsertLine
WordLeft
WordLeft
CursorDown
InsertText "END"
CursorUp
CursorUp



GWD Text Editor menu
System menu
File menu
Edit menu
Search menu
Tools menu
Font menu
Options menu
Window menu
Help menu



System menu
The GWD Text Editor System-menu box is on the far left of the title bar. Click it once or 
press Alt+Spacebar to display the menu.
Restore
Move
Size
Minimize
Maximize
Close
Next
Switch to



File menu
The File menu provides commands for creating new files, opening existing files, saving files,
printing files, and exiting the GWD Text Editor.
New Creates a new file in new edit window.
Open Open an existing file.
Insert File Inserts a file at position of the caret.
Find File Find files matching a filename pattern.
Save Saves the current document.
Save As Saves the current document under a new name.
Save Block Saves the selected text in active document under a new name
Print Prints the current document.
Print Preview View a sample printout of the current document.
Printer Setup Changes the printer and the printing options.
Page Setup Changes the page layout settings.
Exit Quits GWD Text Editor.
1234 Opens the document.
More Files Chooses a file to open from a list.



Edit menu
The Edit menu provides commands to undo, redo, cut, copy, paste, and clear the text in 
edit windows.
Undo Undoes the last editor actions.
Redo Redo the last undone editor action.
Cut Cuts the selected text and puts in on the Clipboard.
Copy Copies the selected text and puts in on the Clipboard.
Paste Inserts text from the Clipboard at the cursor position.
Clear Deletes the selected text.
Cut & Append Cuts the selected text and puts in to the end of Clipboard.
Copy & Append Copies the selected text and puts in to the end of Clipboard
Select All Selects all the of text in the active window.
Column Select Mode Toggles column/stream selection mode.
Fill Block Fills the selected block with a pattern.
Line Draw Starts line drawing.
Line Draw Style Selects line draw style.
Insert Symbol Inserts a special character.
Insert Time/Date Inserts the current date and time.
Word Wrap Toggles word wrap on/off.



Search menu
The Search menu provides commands to search for text and error locations in your files.
Find Finds the specified text
Replace Finds the specified text and replace it with new text
Find Next Repeats last Find or Replace operation
Goto Line Moves cursor to a specific line
Goto Column Moves cursor to a specific column
Match Pair Moves cursor to a matching brace character {([/* */])}
Drop Bookmark Drop a    bookmark at the current cursor position
Goto Bookmark Go to a bookmark position



Tools menu
For more information, choose a command name.
Record Macro
Stop Recorder
Macro
Expand Tabs to Spaces
Compress Spaces to Tabs
Convert Tab Size
Change Case
Convert Text
Sorting
Word Count
GWD Calculator



Font menu
For more information, choose a command name.
Set Font
Windows 1250 CE
Windows 1252
MS-DOS 437
MS-DOS CROSCII
ISO8859-1
ISO8859-2



Options menu
The Options menu contains commands for viewing and changing various default settings in
GWD Text Editor.
Editor Options
Mouse Options
Language
Key Mapping
Help Options
Tools
File Filters
AutoCorrect
Status Bar
Tool Bar
Allow Multiple Instances
Save Desktop Now
Save Desktop on Exit
Restore Desktop Now
Restore Desktop on Start
Save Settings Now
Save Settings on Exit



Window menu
The Window menu contains window management commands.

At the bottom of the Window menu is a list of open windows. If there is more than one 
window active, you can switch to another window and make it active by selecting it from 
the list.
Cascade Arranges the windows in a step ladder fashion.
Tile Arranges the windows so that none overlap.
Arrange Icons Aligns the icons on the bottom.
Close All Closes all child windows.



Help menu
The Help menu provides access to online Help.
Contents Displays help contents for the GWD Text Editor.
Keyboard Displays keyboard information.
What Is Use mouse to select item you want help on.
Keyword Search Displays help about the word at current cursor position.
About Displays version and copyright information.



Restore (System Menu)
This command returns the active window to its previous size. It is only available when the 
active window is maximized or minimized.



Move (System menu)
Use this command to move the active window with the keyboard, rather than by dragging it
with the mouse.
Use the arrow keys to move the window and press Enter when you are done.
This command is not available when the active window is maximized.
You can also move the window by dragging its title bar.



Size (System menu)
Use this command to change the size of the active window with your keyboard.
Use the arrow keys to move the window borders. Press Enter when you are satisfied with 
the window size.
This command is not available if the active window is maximized.



Minimize (System menu)
This command turns the active window into an icon on the GWD Text Editor desktop.
This command is not available if the active window is already minimized.



Maximize (System menu)
This command enlarges the active window to full screen size.
This command is not available if the active window is already maximized.



Close (System menu)
This command closes the active window or, if chosen from the desktop, closes and unloads 
the GWD Text Editor from memory.
If you have modified an Edit window without saving the file first, a Save File dialog box 
appears asking you if you want to save the file before closing.



Next (System menu)
This command makes the next open window or icon active.

Shortcut
Keys Ctrl+F6



Switch to (System menu)
This command displays the Task List dialog box, which you can use to switch from one 
application to another and rearrange application windows.



New (File menu)
The New command opens a new Edit window with the default name NONAMExx.TXT (the xx
stands for a number from 00 to 99) or NNAMxxxx.TXT (the xxxx stands for a number from 
0100 to 9999) and automatically makes the new Edit window active.
The GWD Text Editor prompts you to name a NONAME file when you save it.



Open (File menu)
The Open command displays the Open a File dialog box.
In this dialog box, you select the file you want to open. 



Insert File (File menu)
The Insert    File command displays the Open a File dialog box.
In this dialog box, you select the file you want to insert at the cursor position.



Find File (File menu)
The Find Files command allows you to locate files by filename pattern and/or words and 
phrases among directories and subdirectories.

See also
Find File dialog
How to find file



Save (File menu)
This command saves the file in the active Edit window to disk.
If the file has a default name (such as NONAME00.TXT), the GWD Text Editor opens the 
Save File As dialog box so you can rename the file, as well as save it in a different directory 
or on a different drive.
If you use an existing file name to name the file, the GWD Text Editor asks if you want to 
overwrite the existing file.
If you want to save all modified files, not just the file in the active Edit window, choose Save
All.
This command is available only if an Edit window is currently active.

See also
Save As
Save All
Save Block



Save As (File menu)
The Save As command opens up the Save File As dialog box, where you can save the file in 
the active window under a different name, in a different directory, or on a different drive.
You can enter the new file name, including the drive and directory. 
If you choose an existing file name, the GWD Text Editor asks if you want to overwrite the 
existing file.

See also
Save
Save Block



Save Block (File menu)
The Save Block command opens up the Save File As dialog box, where you can save the 
selected text in the active window.
If you choose an existing file name, the GWD Text Editor asks if you want to overwrite the 
existing file.
This command is available only if text in active window has been marked for selection.

See also
Save
Save As
Insert File



Save All (File menu)
The Save All command works just like the Save command except that it saves the contents 
of all modified files, not just the file in the active window.
This command is disabled if there are no active windows.

See also
Save
Save As



Print (File menu)
This command displays the Print dialog box which lets you print the contents of the active 
window.

See also
Print Setup
Page Setup
Printing header and footers



Print Preview (File Menu)
The Print Preview command opens a special window that shows how the active document 
will appear when printed. The preview window shows one or two pages of the active 
document as they would be laid out on printer pages.    Controls on the window allow you to
move through the pages of the document.



Print setup (File menu)
The Printer Setup command displays the Printer Setup dialog box where you select which 
printer you want to use for printing.

See also
Print
Page Setup
Printer Setup dialog



Page Setup (File menu)
Sets the margins and adds headers and footers to printed appointments.

See also
Page Setup dialog
Printing headers and footers



Exit (File menu)
Exits the GWD Text Editor and removes it from memory.
If you have modified a file without saving it, the GWD Font Editor prompts you to do so 
before exiting.



1234 (File menu)
If you opened files and then closed them during your editing session (by pressing Ctrl+F4), 
the last four files are listed at the bottom of the File menu so you can quickly reopen them.
Choose the file name at the bottom of the menu to reopen the file.

See also
More Files



More Files (File menu)
The More Files command displays the More Files dialog box which displays the last 20 
closed files, so you can quickly reopen them.

See also
1234



Undo (Edit menu)
The Undo command restores the file in the current window to the way it was before your 
most recent edit.
The name of the command changes, depending on what the last action was -- for example, 
Undo Sorting or Undo Typing. The Undo command changes to Can't Undo on the menu if 
you cannot reverse your last action.
The Undo command will not change an option setting that affects more than one window or
reverse any toggle setting that has a global effect; for example, Insert/Overwrite.
Normally GWD Text Editor records the last 20 edit actions that you have performed on each
file that you are editing. You can change this to record more or fewer actions in the Editor 
Options dialog box.

See also
Redo



Redo (Edit menu)
The Redo command reverses the effect of the most recent Undo command.
Redo only has an effect immediately after an Undo command or another Redo command.
A series of Redo commands reverses the effects of a series of Undo commands.

See also
Undo



Cut (Edit menu)
Deletes text from a document and places it onto the Clipboard, replacing the previous 
Clipboard contents.



Copy (Edit menu)
Copies selected text from a active window onto the Clipboard, leaving the original intact 
and replacing the previous Clipboard contents. 



Paste (Edit menu)
Pastes a copy of the Clipboard contents into the current window at the cursor position 
(insertion point).



Clear (Edit menu)
Deletes selected text from a document, but does not place the text onto the Clipboard.
Use Delete when you want to delete text from the document but you have text on the 
Clipboard that you want to keep. 



Cut and Append (Edit menu)
Deletes selected text from a document and appends the selected text to the end of the 
Clipboard without deleting any existing contents of the Clipboard.



Copy and Append (Edit menu)
Appends selected text from a active window to the end of the Clipboard without deleting 
any existing contents of the Clipboard.



Select All
This command selects the entire contents of the active window. You can copy the selected 
text onto the Clipboard, delete it, or perform other editing actions. 



Column Select Mode (Edit menu)
Use this command to alternate between column (block) and normal (stream) selection 
modes



Fill Column Block (Edit menu)
Use this command to fill highlighted column block with a pattern of characters.
This command is available only when you select an column block.

See also
Column Select Mode



Line Draw (Edit menu)
This command allow you to draw lines using direction keys.
This command can be useful for creating boxes, and other text mode drawings.

See also
LineDraw Style



Line Draw Style (Edit menu)
This command displays Line Draw Style dialog box that allows you to select line used to 
draw lines with the direction keys.

See also
Line Draw
Line Draw Style dialog box



Insert Symbol (Edit menu)
Use this command to insert ASCII control code or character that cannot be found on a 
standard keyboard.



Insert Time/Date
Inserts the current time and date into a document at the cursor position (insertion point).



Word Wrap (Edit menu)
Toggles the word wrap mode.

See also
Editor Options dialog box



Find (Search menu)
The Find command displays the Find Text dialog box, where you type in the text you want to
search for.
You can set several options in this dialog box that affect the search.

See also
Replace
Find Text dialog box
Find Next



Replace (Search menu)
The Replace command displays the Replace Text dialog box, where you type in the text you
want to search for and the text you want to replace it with.

See also
Replace Text dialog box
Find
Find Next



Find Next (Search menu)
The Search Again command repeats the last Find or Replace command.
The last settings made in the Find Text or Replace Text dialog box remain in effect when you
choose Find Next.

See also
Find
Replace



Goto Line (Search menu)
The Go to Line command displays the Go To Line Number dialog box that allows you to 
specify the line number you want to find.

See also
Goto Column



Goto Column (Search menu)
The Go to Column command displays the Go To Column dialog box that allows you to 
specify the column number you want to go.

See also
Goto Line



Match Pair (Search menu)
The Match Pair command moves the cursor (insertion point) to a matching brace character
The command checks whether the caret is positioned on a character that is either an 
opening brace from the set { [ ( or /*, or is a closing brace from the set    } ] ) or */. If so, 
GWD Text Editor scans the window in the appropriate direction to locate the brace that 
matches it, with regard to nested brace pairs. If a match is found, the cursor (insertion 
point) is moved to the match pair; if no match is found, the cursor remains where it is.



Match Next Preprocessor Condition (Search menu)
Finds the next matching preprocessor condition.
The command checks whether the cursor (insertion point) is positioned on a line that is an 
C/C++ preprocessor condition (#if, #ifdef, #ifndef, #else or #elif). If so, GWD Text Editor 
scans the file in down direction to locate the preprocessor condition that matches it, with 
regard to nested preprocessor condition pairs. If a match found the cursor (insertion point) 
is moved to the matching condition; if no match is found, the cursor remains where it is.



Match Prev Preprocessor Condition (Search menu)
Finds the previous matching preprocessor condition.
The command checks whether the cursor (insertion point) is positioned on a line that is an 
C/C++ preprocessor condition (#endif, #else or #elif). If so, GWD Text Editor scans the file 
in up direction to locate the preprocessor condition that matches it, with regard to nested 
preprocessor condition pairs. If a match found the cursor (insertion point) is moved to the 
matching condition; if no match is found, the cursor remains where it is.



Drop Bookmark (Search menu)
The Drop Bookmark command inserts one of ten numbered markers at the cursor position.   
Use the Go To Bookmark command to return to one of these locations.



Go to Bookmark (Search menu)
Go to Bookmark command moves the cursor (insertion point) to one of the ten numbered 
bookmarks.

See also
Drop Bookmark



Record Macro (Tool menu)
The Record Macro command displays the Record Macro dialog box, where you can start 
recording your key presses and menu selections as a keyboard macro.
Note: The macro recorder cannot record mouse actions. You must use keys when recording 
actions such as moving the cursor (insertion point) and selecting text. However, you can 
use the mouse to choose commands and select options when recording a macro.

See also
Recording a macro
Record Macro dialog box
Using Macros



Stop Recorder (Tool menu)
This command stops recording your key presses and menu selections as a keyboard macro

See also
Record Macro



Macro (Tool menu)
This command displays the Macro dialog box where you can run, edit or delete any macro.

See also
Macro dialog box
Recording a macro
Using Macros



Expand Tabs to Spaces
This command expands tab characters to the appropriate number of spaces.

See also
Compress Spaces to Tabs
Convert Tab Size



Compress Spaces to Tabs (Tool menu)
This command compresses occurrences of multiple spaces to tabs, where appropriate. 
Spaces within quotes (single and double) are not compressed.

See also
Expand Tabs to Spaces
Convert Tab Size



Convert Tab Size (Tool menu)
This command displays Convert Tab Size    dialog box where you can convert text file 
written in text editor with (n) tab size to text file with (n) or current tab size.

See also
Expand Tabs to Spaces
Compress Spaces to Tabs



Change Case (Tool menu)
The Change Case command displays Change Case dialog box where you can change the 
capitalization of selected text.



Convert Text (Tool menu)
The Convert Text command displays Convert Text dialog box where you can convert 
character set.
If there is a selected text when this command is executed, only characters in the selected 
text are converted; otherwise this command affects the entire file.



Sorting (Tool menu)
The Sorting command displays Sorting dialog box that allows you to arrange selected lines 
alphabetically or numerically.
GWD Text Editor allows you to sort a range of lines, using a selected Block as the key upon 
which the sort is based.

You can also use column block (see Column Select Mode command ) to specify sorting key:

See also
Sorting dialog box



Word Count (Tools menu)
Counts the number of words, characters, paragraphs, and lines in the active document.



GWD Calculator (Tools menu)
Runs GWD Calculator or Windows Calculator if GWD Calculator is not installed.



Set Font (Font menu)
The Set Font command starts a standard Choose Font dialog box that allows you to specify 
the typeface to be used,    the type style (i.e. regular, bold or italic), and the type size. The 
selection applies to all windows.
Note that you can select only fixed pitch fonts.
You can create Windows bitmap fonts using GWD Font Editor.



Fonts (Font menu)
Windows 1250 CE
Specifies that text is to be shown using the standard ANSI (Central European) fixed pitch 
font.
Windows 1252
Specifies that text is to be shown using the standard ANSI fixed pitch font.
MS-DOS 437
Sets the screen font to the standard MS-DOS (CodePage 437) fixed pitch font.
MS-DOS CROSCII
Specifies that text is to be shown using the standard Croatian 7-bit fixed pitch font.
ISO 8859-1
Specifies that text is to be shown using the standard ISO8859-(Latin I) fixed pitch font.
ISO 8859-21 
Specifies that text is to be shown using the standard ISO8859-2 (Latin II) fixed pitch font.

You can use GWD Font Editor to create your own Windows bitmap fonts.

See also
Set Font



Editor Options (Options menu)
The Editor command displays the Editor Options dialog box, where you specify how you 
want the GWD Text Editor to handle text in Edit windows.



Mouse Options (Options menu)
The Mouse command displays the Mouse Options dialog box, where you specify settings 
which define how your mouse works.



Language (Options menu)
The Language command opens the Language dialog box, where you can specify language 
(this is interesting only to folks in Croatia).
GWD Text Editor uses language codes to tailor several features (sorting, case conversion, 
etc.)



Key Mapping (Options menu)
The Key Mapping command opens the Key Mapping dialog box where you can modify key 
assignments for commands and macros.

See also
Key Mapping dialog box



Help Options (Options menu)
The Help Options command opens the Help Options dialog box where you can add items on
the Help menu.



Tools (Options menu)
The Tools command opens the Tools dialog box,    where you can add, delete or modify the 
tools listed under the Tool menu. The Tool menu lets you run tools of your choice without 
leaving the GWD Text Editor.

See also
Tools dialog box



File Filters (Options menu)
The File Filters command opens the File Filters dialog box, where you can add, delete or 
modify file filters for Open and Save As dialog boxes.

See also
File Filters dialog box



Syntax Highlighting (Options menu)
The Syntax Highlighting command opens the SyntaxHighlight dialog box where you can 
specify how you want the different syntax elements of your source code to appear in the 
Edit window. You can also define Syntax Highlighting for languages that are not known by 
GWD Text Editor.



AutoCorrect (Options menu)
The AutoCorrect comand opens the AutoCorrect dialog box where xou can add, delete or 
modify AutoCorrect entries.

See also
AutoCorrect dialog box



Status Bar (Options menu)
Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state.
A check mark appears next to the menu item when the Status Bar is displayed.

For more information, see Status Bar.



Toolbar (View menu)
This command displays or hides the Toolbar, which includes buttons for some of the most 
common commands in GWD Text Editor, including Open, Copy, and Print.

For more information, see Toolbar.



Allow Multiple Instances (Options menu)
The Allow Multiple Instances command determines whether more than one instance of the 
program can be run at the same time.

Tips
If you hold down CTRL key when you run new instace of program or open documment 
asociated with GWD Text Editor. GWD Text Editor will always create new instance of 
program.
If you hold down SHIFT key when you run new instace of program or open documment 
asociated with GWD Text Editor. GWD Text Editor will allways load documment in previous 
instance.



Save Desktop Now (Options menu)
The    Save Desktop Now command saves the workspace immediately. Saved workspace 
can be restored with Restore Desktop Now or Restore Desktop on Start commands.



Save Desktop on Exit
The Save Desktop on Exit command determines whether current workspace is 
automatically saved when GWD Text Editor is closed.

See also
Restore Desktop



Restore Desktop (Options menu)
When the GWD Text Editor is brought up (i.e. executed) it can come up with a record of the 
files that were being edited when the editor was last terminated. This can be very useful if 
a particular file (or set of files) is frequently edited. Restore Desktop specifies whether this 
option is desired or not.



Save Settings Now (Options menu)
The Save Settings Now command saves the options immediately.



Save Settings on Exit (Options menu)
The Save Settings on Exit command determines whether options are automatically saved 
when GWD Text Editor is closed.



Cascade (Window menu)
This command overlaps open windows so all widows are the same sizes and only part of 
each underlying window is visible.



Tile (Window menu)
This command arranges the windows so they cover the entire desktop without overlapping.



Arrange Icons (Window menu)
The Arrange Icons command rearranges any icons on the desktop.
Rearranged icons are evenly spaced, beginning at the lower left corner of the desktop.



Close All (Window menu)
The Close All command closes all open windows on the desktop.
If the file was modified since last time saved, the GWD Text Editor opens a dialog box that 
asks if you want to save the file before closing the window. 



Contents (Help menu)
The Contents command displays the GWD Font Editor on-line Help contents. It provides a 
comprehensive list that summarizes the organization of topics in the Help system.



Keyboard (Help menu)
Use this command to get Help about keyboard shortcuts.

See also
Keyboard shortcuts



What Is (Help menu)
This command enables you to display help information for any item on the screen or in a 
dialog box.    When you choose What Is from the Help menu, the mouse pointer is changed 
to an arrow with a question balloon. Position the pointer on the item in question, then click 
to display the specific help for it.    You can also press Shift+F1 to activate What Is.



Keyword Search (Help menu)
If you place your cursor on a word in the active window and choose this command, a Help 
window opens with information about that word.
You can set up the Right Mouse button (in the Mouse Options dialog box) to do a topic 
search. 
By default, GWD Text Editor uses the help file specified in Help Options dialog box as the 
active help file.
If the help file contains an exact match for the text, you will see the appropriate help entry;
if not, you will see a list of possible topics that might match.



About (Help menu)
When you choose the About command, the About GWD Text Editor dialog box appears, 
showing copyright and version information.



Open Source File (Popup menu)
This command opens the file at the current cursor position. GWD Text Editor understands 
the C preprocessor's #include syntax, so selecting an #include line and invoking Open 
Source File will opens this file.
GWD Text Editor search for file in following directories:
 1. Current active text file directory.
 2. Directories specified in INCLUDE environment variable.
 3. Directories (that ends with \BIN) specified in PATH environment variable (GWD Text 

Editor replaces \BIN with \INCLUDE, MFC\INCLUDE and OWL\INCLUDE).
 4. Current directory.

GWD Text Editor will almost always find Borland C++, MS Visual C++ and Clipper include 
files.



 Keyboard definition

Cursor movement
Selecting text
Insert and delete text
Block commands
Block commands (WordStar/Borland style)
Searching text
Bookmarks
Other commands



 Cursor movement
Command Keys
Character left Left
Character right Right
Word left Ctrl+Left
Word right Ctrl+Right
Line up Up
Line down Down
Scroll up
Scroll down
Page up PgUp
Page down PgDn
Beginning of line Home Ctrl+Q+S
End of line End Ctrl+Q D
Top of window Ctrl+Q E
Bottom of window Ctrl+Q X
Paragraph up Ctrl+Up
Paragraph down Ctrl+Down
Top of file Ctrl+HomeCtrl+Q R
End of file Ctrl+End Ctrl+Q C
Previous tabulator Shift+Tab
Go to line Ctrl+J
Go to column



 Selecting text
Command Keys
Left one character Shift+Left
Right one character Shift+Right
Left one word Shift+Ctrl+Left
Right one word Shift+Ctrl+Right
End of line Shift+End
Beginning of line Shift+Home
Line up Shift+Up
Line Down Shift+Down
One page down Shift+PgDn
One page up Shift+PgUp
End of file Shift+Ctrl+End
Beginning of file Shift+Ctrl+Home
Paragraph up Shift+Ctrl+Up
Paragraph down Shift+Ctrl+Down
Select word Ctrl+K+T
Select line Ctrl+K+L
Top of Window
Bottom of Window
Scroll up
Scroll down
Select All Ctrl+A
Column selection mode Ctrl+O C
Normal selection mode Ctrl+O K



 Insert and delete text
Command Keys
Delete character to left Backspace Ctrl+H
Delete character Del Ctrl+G
Delete line Ctrl+Y
Delete to end of line Shift+Ctrl+YCtrl+Q Y
Delete to begin of line Ctrl+Q Del
Delete word Ctrl+T
Delete word to left Ctrl+Backspace
Insert line Ctrl+N
Insert mode on/off Insert



 Block commands
Command Keys
Set beg of block Ctrl+K B
Set end of block Ctrl+K K
End selecting Ctrl+K H
Mark line Ctrl+K L
Mark word Ctrl+K T
Delete block Del Ctrl+K Y
Copy to Clipboard Ctrl+C Ctrl+Ins
Cut to Clipboard Ctrl+X Shift+Del
Paste from Clipboard Ctrl+V Shift+Ins
Indent block Ctrl+K I
Unindent block Ctrl+K U
Print block Ctrl+K P
Read block from disk Ctrl+K R
Write block to disk Ctrl+K W
Uppercase block Ctrl+K N
Lowercase block Ctrl+K O
Flip case Ctrl+O O



 Block commands (WordStar/Borland style)
Command Keys Function
Text selection ON Ctrl+K B Begins the selection of text. Text selection ends with 

copying (Ctrl+K K) or cutting (Ctrl+K V) to the Clipboard or 
turning text selection off with Ctrl+K H.

Sets end-of-block Ctrl+K K Marks the end of selected block and copying to the 
Clipboard.

Text selection OFF Ctrl+K H Stops the selection of text and the selected text becomes 
unselected.

Copy block Ctrl+K C Copies block of marked text to the current cursor position.



 Searching text
Command Keys
Search Ctrl+S Ctrl+F Ctrl+Q+F
Search/replace again F3 Ctrl+L
Find next word Ctrl+F3
Find previous word Ctrl+Shift+F3
Replace string Ctrl+Q+A
Pair matching Ctrl+Q [ Ctrl+Q ]



 Bookmarks
Command Keys
Set bookmark 0 Ctrl+K+0
Set bookmark 1 Ctrl+K+1
Set bookmark 2 Ctrl+K+2
Set bookmark 3 Ctrl+K+3
Set bookmark 4 Ctrl+K+4
Set bookmark 5 Ctrl+K+5
Set bookmark 6 Ctrl+K+6
Set bookmark 7 Ctrl+K+7
Set bookmark 8 Ctrl+K+8
Set bookmark 9 Ctrl+K+9
Go to bookmark 0 Ctrl+Q+0
Go to bookmark 1 Ctrl+Q+1
Go to bookmark 2 Ctrl+Q+2
Go to bookmark 3 Ctrl+Q+3
Go to bookmark 4 Ctrl+Q+4
Go to bookmark 5 Ctrl+Q+5
Go to bookmark 6 Ctrl+Q+6
Go to bookmark 7 Ctrl+Q+7
Go to bookmark 8 Ctrl+Q+8
Go to bookmark 9 Ctrl+Q+9



 Other editor commands
Command Keys
Autoindent mode on/off Ctrl+O I
Autounindent mode on/off Ctrl+O U
Pair matching Ctrl+Q [ Ctrl+Q ]
Insert symbol (control char) Ctrl+P
Set marker Ctrl+K n*
Find place marker Ctrl+Q n*
Save file F2 Ctrl+K S
Tab Tab Ctrl+I
Uppercase Ctrl+K+N
Lowercase Ctrl+K+O
Flip case Ctrl+O O
Center line Ctrl+O+T
Insert C/C++ comment Shift+Ctrl+C
Undo Ctrl+Z Alt+BkSp
Redo Alt+Shift+BkSp
Open file at cursor positionCtrl+O A
Print Ctrl+K P
Help F1
Help on a command Shift+F1
Extern help for keyword Ctrl+F1

* n represents a number from 0 to 9



Dialog boxes
The GWD Text Editor includes this dialog boxes:

AutoCorrect
Change Case
Editor Options
File Filters
Find File
Find Text
Go To Column
Go To Line
Help Options
Key Mapping
Line Draw Style
Macro
Mouse Options
Open File
Page Setup
Print
Printer Setup
Record Macro
Replace Text
Save File As
Sorting
Syntax Highlight
Tools
Tool Arguments



Open File dialog box
Use the Open File dialog box to open any text file.

File Name
The input box lets you enter the name of the file to open, or a file specification to limit the 
files that display in the list box. 
The list box displays the names of files in the current directory that match the file 
specification in the input box. You can select more than one file.
Directories (Folders)
Lets you select the directory which contains the files you want.
List Files of Type
Lets you select which file types you want displayed. You can create your own List (see File 
Filters command).
Drives
Lets you select the drive that contains the files you want.
Find File
Allows you to locate files by filename pattern and/or words and phrases among directories 
and subdirectories.



Save As dialog box
Use the Save As dialog box to save the contents of the active file in a different file.

File Name
The input box lets you enter the name of the file to save, or a file specification to limit the 
files that display in the list box. 
The list box displays the names of files in the current directory that match the file 
specification in the input box.
Directories (Folders)
Lets you select the directory which contains the files you want.
List Files of Type
Lets you select which file types you want displayed. You can create your own List (see File 
Filters command).
Drives
Lets you select the drive which contains the files you want.
File Format
Lets you select file format in which the file will be saved.



Find File dialog box
Use this dialog box to locate files by filename pattern and/or words and phrases among 
directories and subdirectories.

File Pattern
Type the name of the document or the type of document you want to find. You can use 
wildcard characters to customize your search if you cannot remember the exact filename.
Containing
Enter a text string to search for. If this is left blank Find File will perform a file search only.
Search

Current Directory Search in current directory only.
Current SubtreeSearch in current directory and all of its subdirectories.
Entire Disk Search in all directories of the current disk.
Drive Select the drives in which you want to search for a document.
All Local Drives Searches in all fixed (or hard) drives on your computer.
All Drives Searches in all fixed drives, including network drives, to which your 

computer has access.
Edit Dir
Selects searching directory.



Print dialog box
Use the Print dialog box to print the current file to any printer that you have installed for 
Windows.

Font
Allows you to change printer font that GWD Font Editor will use for printing.
Print range
Prints either all of the source file or selected text only.
Split Long Lines
Uses multiple lines to print characters beyond the page width. If this option is off, lines are 
truncated and characters beyond the page width do not print.

See also
Page Setup
Print Preview



Printer Setup dialog box
Use this dialog to select a printer and a printer connection.

Printer
Lists the available printers. Click the printer you would like to use. To add a printer, open 
the Printers folder, and then double-click Add Printer.
Orientation
Specifies whether the document should be printed with its top along the short edge of the 
paper (portrait) or along the long edge of the paper (landscape).
Paper
Lists the available choices for paper size and source.



Page Setup dialog box
Use this dialog box to:
- Set the margins on printed pages.
- Specify the text for running headers and running footers on each page.
Header
The text printed at the top of every printed page. The header is always centered and prints 
1.25cm (0.5") from the top of the page. You can use special character sequences in header 
to insert corresponding information automatically.
Footer
The text printed at the bottom of every printed page. The footer is always centered and 
prints 1.25cm (0.5") from the bottom of the page. You can use special character sequences 
in header to insert corresponding information automatically.
Start page numbers at
Specifies the starting number you want to print on the first page.
Margins
The width, in centimeters (or inches), of each margin on every printed page.

Tips and Troubleshooting      You can use the following special character sequences in 
headers and footers to insert the corresponding information automatically:
To Print Use
Filename &f
Page number of current page &p
Current system time &t
Current system date &d
Left aligned &l
Centered &c
Right aligned &r
With some printers, the minimum margin is determined by the physical characteristics of
the printer. For instance, some laser printers cannot print on the top 0.25" or on the left 
0.25" of any page.
The base page size for the printer is set when you install the printer or modify the 
installation. You can use the Printer Setup command on the File menu to determine the 
page size or modify it.



Line Draw dialog box
Use the Line Draw Style dialog box to select line used to draw lines with the direction keys.

If you use 'MS-DOS Single', 'MS-DOS Double', 'MS-DOS Double Top' or 'MS-DOS Double Side'
line draw style, you must select an MS-DOS font.



Find Text dialog box
Use the Find Text dialog box to specify the text you want to search for.

Find Text
The Text to Find input box is where you enter the search string.
Match Whole Word Only
Matches text strings only if they are preceded and followed by a space, tab, or punctuation 
character, or the start or end of a line. Otherwise, the command matches any string, 
whether it is a fragment of a larger string or not.
Match Case
When the Match Case option is on, the editor differentiates uppercase from lowercase when
performing a search.
Regular Expression
When this option is on, the editor recognizes GREP-like wildcards in the search string.
Direction
The Direction options specify which way you want the editor to search, starting from the 
current cursor position.



Regular Expression
The following table lists valid regular expressions.

RegExp. Description
    . Matches any single character
    ^ A circumflex at the start of the string matches the start of a line.
    $ A dolar sign at the end of the expression matches the end of a line.
    * Matches any number of occurrences (including zero) of that character. For 

example, bo* matches bot, b, boo, and also be.
    + Matches one or more occurrences of that character. For example, bo+ matches 

bot and boo, but not b or be.
    ? Matches a match of that character or null string. For example, bo? matches bo, 

and b
[    ] Characters in brackets match any one character that appears in the brackets, but

no others. For example [bot] matches b, o, or t.
[ - ] A hyphen within the brackets signifies a range of characters. For example, [b-o] 

matches any character from b through o.
[^] A circumflex at the start of the string in brackets means NOT. Hence, [^bot] 

matches any characters except b, o, or t.
{ } Any sequence of characters between the braces. For example, {my}+text finds 

mytext mymytext, mymymytext, and so on. Note that it will not find mtext, ytext,
or ymtext, because the sequence my is not in any of those strings.

    | Or operator. For example first|last finds first or last.
    \    A backslash before a wildcard character treat that character literally, not as a 

wildcard. For example, \^ matches ^ and does not look for the start of a line. You 
can also use \t and \f to find tabulator and form feed characters.

In replace edit box you can use \t and \n to insert tabulator and new line.



Nije ukljuceno zbog strlwr/strupr

    & In the Replace With text box substitutes the entire string that was matched in the
Find What text box.

Tagged Expressions
A tagged expression is an regular expression that starts with the { and ends with the }. 
There can be up to nine such expressions. Such an expression matches the same as the 
expression without the surrounding { and }.    The first expression defined in this way can 
be referenced as \1 in the Replace With text box, and so on up to \9.
If the expression in the Find What text box is {psz}OldString, and the expression in the 
Replace With text box is \1NewString, all selected occurrences of pszOldString are 
replaced with pszNewString.
Preceding & or \1-9 with \U, \u, \L, or \l adjusts the \case \of the inserted text. \u and \l 
change only the first character, while \U and \L change the entire string to upper or lower 
case. In Replace With text box you can also use \t, \n, and \f to insert tab, newline, and form
feed.



Replace Text dialog box
The Replace Text dialog box is where you specify the text to search for and what to replace 
it with.

Find What
The Text to Find input box is where you enter the search string.
Replace With
Enter the replacement string in the Replace With input box.
Match Whole Word Only
Matches text strings only if they are preceded and followed by a space, tab, or punctuation 
character, or the start or end of a line. Otherwise, the command matches any string, 
whether it is a fragment of a larger string or not.
Match Case
When the Match Case option is on, the editor differentiates uppercase from lowercase when
performing a search.
Prompt on Replace
When the Prompt on Replace option is on, the editor prompts you before replacing each 
time it finds the search string.
Direction
The Direction options specify which way you want the editor to search, starting from the 
current cursor position.
Replace
Replaces first string that matches the string specified in the Find What text box.
Replace All
Replaces all strings that match the Find What string automatically.



Go To Line Number dialog box
Use this dialog box to find a specific line number in active file.

Go To Line Number
Enter a specific line number, then press Enter (or choose OK).



Go To Column Number dialog box
Use this dialog box to find a specific column number in active file.

Go To Column Number
Enter a specific column number, then press Enter (or choose OK).



Macro dialog box
Use this dialog box to run, edit or delete macro.

Macro Name
Select the macro you want to run or edit.
Run
Run the selected macro.
Edit
Displays the contents of the selected macro for review or editing.
Delete
Deletes the selected macro.
Rename
Displays the Rename Macro Name dialog box, in which you can type a new name for the 
selected macro.
Description
Change the description for the selected macro to remind you of its function.
See also
Using Macros



Record Macro dialog box
Use this dialog box to record a macro --- a series of actions that you want to "play back" in 
sequence later.

Record Macro Name
Type a name for the macro. Do not use spaces.
Shortcut Key

You can select a shortcut key to make it easier to run the macro later.
Ctrl Adds the CTRL key to the key combination.
Shift Adds the SHIFT key to the key combination.
Key Adds a letter key, function key, or other available key to the key combination.
Currently Displays the current key assignment for the macro you select.

Description
Type a short description of the macro function.
See also
Using Macros



Change Case dialog box
You can use the Change Case dialog box to change the selected characters to all uppercase
letters, all lowercase letters, or a combination of uppercase and lowercase letters.

Sentence case.
Capitalizes the first letter of the first word in the selected sentence, or the first word after 
the end of a sentence.
lowercase
Changes all of the selected text to lowercase.
UPPERCASE
Changes all of the selected text to uppercase.
Title Case
Capitalizes the first letter of each word in the selection.
tOGGLE cASE
Changes all uppercase letters to lowercase letters and all lowercase letters to uppercase 
letters in the selection.



Sorting dialog box
Use this dialog to arrange selected paragraphs alphabetically or numerically.

Sorting Order
Select a sort order:
Ascending Puts the beginning of the alphabet or the lowest number at the top of the 

sorted items.
Descending Puts the end of the alphabet or the highest number at the top of the 

sorted items.
Key Field

Specify how you want to sort.
Alphanumeric Uses numbers, text, and all other characters to sort items.
Numeric Uses only numbers to sort items. GWD Text Editor ignores all other 

characters.
Field start Specify the column to sort by.
Field length Specify how many characters will be used for the sort key.

Case Sensitive
Sorts the list so that a word whose first letter is a capital letter precedes any word whose 
first letter is the same in lowercase.

GWD Text Editor allows you to sort a range of lines, using a selected Block as the key upon 
which the sort is based:



Editor Options dialog box
You can use the Editor Options dialog box to set options that specify how the GWD Text 
Editor handles text.
Insert Mode
When the Insert Mode option is on, the text you type is inserted, pushing the existing text 
to the right. When this option is off, any text you type overwrites existing text.
To toggle Insert mode when you're working (without changing the default setting), press 
Ins.
Auto Indent Mode
When the Auto Indent Mode option is on, pressing Enter in an Edit window positions the 
cursor under the first nonblank character in the preceding nonblank line.
Backspace Unindent
When the Backspace Unindent option is on and the cursor is on a blank line (or on the first 
nonblank character of a line), the Backspace key aligns the line to the previous indentation 
level.
Use Tab Character
When the Use Tab Character option is on, the editor inserts a tab character (ASCII 9) when 
you press Tab. When this option is off, the GWD Text Editor replaces tabs with spaces.
Leave Undo After Save
When the Leave Undo After Save option is on, you can perform Undo command after the 
file has been saved. When this option is off, Undo command cannot be performed after the 
file has been saved.
Visible Right Margin
When the Visible Right Margin option is on, you should see a dark gray vertical line appear 
at the 'Word Wrap at' setting.
Tab Size
The Tab Size input box dictates how many characters the cursor moves for each tab stop.
Block Indent
Block Indent input box allows the user to specify the number of characters blocks are 
indented when the block indent and block unindent commands are used.
Undo Levels
Undo Levels input box allows you to specify the number of undo levels.
Word Wrap At
With this option is on, GWD Text Editor will automatically break the text you type at the 
specified column.
Create Backup File
When the Create Backup Files option is on and you choose Save command, the GWD Text 
Editor automatically creates a backup of any existing file of the same name.
Detect File Format When Loading
When this option is on GWD Text Editor will automatically detect text file format (DOS, UNIX
or Macintosh) when you open an file. When you save file GWD Text Editor will save file in 



this format. When this option is off GWD Text Editor will save file in the format specified in 
Default File Format settings.
Default File Format
Default File Format allows you to specify text file format that will be used when you save 
file.



Mouse Options dialog box
You use the Mouse Options dialog box to customize the actions of the mouse in the GWD 
Text Editor.

Right Mouse Button
The Right Mouse Button options determines what happens when you press the right mouse 
button.



Keyboard Mapping dialog box
Use this dialog box to modify key assignments for commands and macros.

Shortcut Key
Select the keys you want to assign to the selected command or macro.

Prefix key If the key you want to map is a prefix key, select the prefix key from the 
drop-down list. If the prefix key you want to use does not appear in the list, 
click the Configure button to display the Prefix Key dialog box.

Alt Select this check box to make the ALT key part of a shortcut key 
combination.

Ctrl Select this check box to make the CTRL key part of a shortcut key 
combination.

Shift Select this check box to make the SHIFT key part of a shortcut key 
combination.

Key Type or select the key you want to assign as a shortcut key. Note: Some 
keys do not appear because they cannot be assigned.

Currently Displays the current assignment for the shortcut keys you select.
Configure Adds, deletes or changes prefix keys.

Show
Select the type of features to which you want to assign keys:

Commands Displays GWD Text Editor commands.
Macros Displays your macros.

Commands/Macros
Select the command or macro to which you want to assign keys.
Current Keys For
Displays the existing key assignments for the command or macro you select in the 
Commands/Macros box.
Macro/Command Description
Displays the description for the command or macro you select in the Commands/Macros 
box.
Add
Adds the key assignment displayed under Shortcut Key to the selected command or macro.
Change
Changes the key assignment displayed under Shortcut Key to the selected command or 
macro.
Delete
Deletes the key assignment you select in the Current Keys For box.



Help Options dialog box
Use the Help Options dialog box to add items to the Help Menu.

Menu String
Specifies what you want to see on the help menu for the item.
Help File Name
Specifies the name of the help file to be opened when you click the menu item. You must 
specify a full path name for the file.
Active
Active help file specifies the name of the Windows help file to be used by Keyword Search 
command (Ctrl+F1).



Tools dialog box
Use the Tools dialog box to add programs to the Tools menu. You can then start the 
programs by selecting them from the Tools menu.

Menu Contents
The list of programs currently displayed on the Tools menu.
Menu Text
The text that you want to appear on the Tools menu to identify this program.
Command
The file specification necessary to run the program. This can include the drive and directory
path, and must include the filename for the program. You can also use $(ProgDir) macro 
(see Arguments).
Arguments
Command line arguments (see Arguments).
Initial Directory
The current directory when the program runs. You can use the predefined macros described
for the Arguments option.
Prompt for Arguments
When checked, displays a dialog box for additional arguments for the program each time 
you start the program, in addition to the arguments that are automatically used every time 
the program starts.
Redirect to Output Window
The output from the tool is displayed in an Output window. Use this option only for MS-DOS 
programs.
Add
Displays the Add Tools dialog box. After you select the drive and directory to examine, you 
can pick a program from the list displayed. When you dismiss the dialog box, the program 
appears in the Menu Contents list, with its name and path in the text boxes. You can then 
specify additional information for the tool.
Remove
Deletes the program currently selected in the Menu Contents list from the Tools menu.
Move Up
Moves the program currently selected in the Menu Contents list up one position in the list.
Move Down
Moves the program currently selected in the Menu Contents list down one position in the 
list.



Arguments
You can use the following predefined dynamic macros in the argument list:

Macro Description
$(FilePath) Current fully qualified text file name. It is null if a non-text window is active.
$(FileName) Current active text file basename and extension. It is null if a non-text 

window is active.
$(FileExt) Current active text file extension. It is null if a non-text window is active.
$(FileDir) Current active text file drive and directory (ending in \). It is null if a non-text 

window is active.
$(ProgDir) GWD Text Editor directory (ending in \).
$(CurDir) Current working directory (ending in \).
$(CurText) The current text (the word under the current cursor position).
$(CurLine) Current line containing the insertion point (cursor) within the active window.
$(CurCol) Current column containing the insertion point (cursor)    within the active 

window.
$(CurDir) Current working directory (ending in \).

Note: In the Initial Directory box, you can also use macros that expand to a directory. 
Macro $(ProgDir) can also be used in the Command box.

Macro recognition is not case sensitive. All path macros end in a backslash (\).



Tool Arguments dialog box
The Tool Arguments dialog box is where you type in command-line arguments for your 
programs exactly as if you had typed them on the DOS command line. 



File Filters dialog box
Use the File Filters dialog box to add, modify or delete filters for Open and Save As dialog 
boxes.

Files of Type
The list of filters currently displayed in the Open and Save As dialog box.
Description
The text that you want to appear in the Files of Type drop down list box in Open File dialog 
box.
Filter
Wildcard string defining the files accepted by the current filter.
Add
Adds new file filter.
Remove
Deletes the filter currently selected in the Files of Type list.
Move Up
Moves the filter currently selected in the Files of Type list up one position in the list.
Move Down
Moves the filter currently selected in the Files of Type list down one position in the list.



Syntax Highlighting dialog box
Use the Syntax Highlighting dialog box to set the colors that GWD Text Editor uses to 
display syntax elements in your source code.

File Type
The list of file types (languages) that will be highlighted.
File Extensions
Specifies which files will be displayed with syntax highlighting table specified in File Type 
list box. Multiple file extensions must be separated with spaces.
Element
The Element list box lists the syntax elements whose color (highlighting) you can alter.
Color
The color used to display sintax element.
Add
Adds new language.
Remove
Deletes the file type (language) selected in File Type list box.
Edit
Displays dialog box that allow you to specify language syntax.



Case Sensitive
Enables or disables case sensitivity when scanning for keywords.
UNIX Tex Like Keywords
If this option is on, GWD Text Editor assumes that all words that begin with \ character is 
keywords.



AutoCorrect dialog box
Use the AutoCorrect dialog box to customize the settings used to correct text automatically 
as you type.

Correct Two Initial Capitals
If you type two consecutive uppercase letters in a word, changes the second uppercase 
letter to a lowercase letter.
Capitalize First Letter Of Sentences
Capitalizes the first letter of each sentence.
Exceptions
Displays dialog box where you can enter abbreviations that you don't want to correct 
automatically.
Replace Text As You Type
Corrects text automatically as you type.
Add
Adds the AutoCorrect entry displayed in the Replace and With boxes.
Replace
Replaces the AutoCorrect entry displayed in the Replace and With boxes. 
Delete
Deletes the AutoCorrect entry displayed in the Replace and With boxes.



Procedures
Adding commands to the Tools menu
Adding items to the Help menu
Editing a macro
Find file
Previewing a document before printing
Printing headers and footers
Recording a macro
Running a macro



Adding commands to the Tools menu
You can add up to eight commands to the Tools menu, including MS-DOS commands, as 
well as MS-DOS and Windows-based applications.
To add a command to the Tools menu
 1. From the Options menu, choose Tools. The Tools dialog box appears.
 2. Choose Add from the Tools dialog box. The Add Tool dialog box appears.
 3. Select the drive and directory to locate your program (for example CLIPBRD.EXE).
 4. Choose OK. The Tools dialog box is displayed again.
 5. Optionally, give a name for the Clipboard Viewer accessory in the Menu Text box. By 

default the base name of the EXE file is given.
You can assign a mnemonic to a tool (a mnemonic is the letter used to run a command 
on a menu). An ampersand (&) before a letter in the name marks the letter as the 
mnemonic. For example, the entry Clipboard &Viewer designates V as the mnemonic to 
open the application. By default, the first letter in the name is used.

 6. You can also add arguments to be passed to the program by typing them in the 
Arguments text box (see Argument Macros) or set the initial directory for your program 
by typing it in the Initial Directory text box.

 7. Chose Close
The command now appears on the Tools menu. To run the program, choose it from the 
menu.



Adding items to the Help menu
You can add up to five items to the Tools menu.
To add a help
 1. From the Options menu, choose Help Options command. The Help Files dialog box 

appears.
 2. In the Menu String input box specify what you want to see on the help menu for the 

item. If you include an "&" character in the string, the character following it will appear 
underlined, and will be used as the menu item's hot key

.3. In the Help File Name input box, enter the name of the help file. You must either give 
a full path name for the file, or it must be in a directory named in the PATH environment 
variable. You can use Browse button to locate your help file.



Editing a macro
You can edit macros you write or record in the macro editing dialog.
To edit a macro
1. From the Tools menu, choose Macro.
2. In the Macro Name list box, select the macro you want to edit.
3. Choose the Edit button.

The macro appears in the macro editing dialog.
4. Edit the macro.
5. Choose the Close button.



Find File
You can use the Find Files command to locate files by filename pattern and/or words and 
phrases among directories, subdirectories or disks.
To find a file
1. From the File menu, choose Find Files.
2. If you wish to change your directory, choose the Edit Dir button.
3. Type a file pattern for the file you require in the File Pattern text box. You can use 

wildcard characters to customize your search if you cannot remember the exact 
filename.

4. If you cannot remember exact file name, you can type text from the document you wish 
to find in the Containing text box to minimize search time.

5. Chose Find.



Previewing a document before printing
You can use the Print Preview command to show how a document will look when you print 
it.
To preview a document before printing
1. From the File menu, choose Print Preview command.
2. If you have not already specified the printer font the Printer Font dialog box appears. If 

you do not specify the printer font, document will be printed using default printer font.
2. To see two pages at a time, choose the Two Pages button.
3. To view different pages in the document, use the tool bar or the PAGE UP and PAGE 

DOWN keys
4. To return choose the Close button or press ESC.



Printing Headers and Footers
To print a header or footer
 1 From the File menu, choose Page Setup. 
 2 Type the header or footer text, codes, or both, and then choose the OK button. 

Type For
&d The current date 
&p Page numbers 
&f The current filename 
&l Text (following the code) to be aligned at the left margin 
&r Text (following the code) to be aligned at the right margin 
&c Text (following the code) to be centered between the margins 
&t The current time 



Recording a macro
The macro recorder cannot record mouse actions in document text. You must use keys 
when recording actions such as moving the insertion point and selecting text. However, you
can use the mouse to choose commands and select options when recording a macro.
To record a macro
1. From the Tools Menu choose Record Macro command.
2. In the Record Macro Name input box, type a name for the macro.

If you want to run the macro with a shortcut key, specify a key or combination of keys 
under Shortcut Key.
You can type short description of the macro in the Description box.

3. Choose the OK button.
4. Perform the actions you want to record.
5. From the Tools menu, choose Stop Recorder.
See also

Running a macro



Running a macro
You can use the Macro command to run any macro.
To run a macro
1. From the Tools menu, choose Macro command.
2. In the Macro Name list box, select the macro you want to run.
3. Choose the Run button.



GWD Text Editor screen
Click the part of the Word screen, below, that you want information on:



Toolbar
Toolbar contains buttons that give you quick access to many commands and features. To 
see the description of a button in Status bar, point to it with the mouse. To display or hide 
toolbars, use the Toolbar command on the Options menu.



Status Bar
Shows information and messages at the bottom of the GWD Text Editor window. Displays 
information about a command or toolbar button, or the location of the insertion point 
(cursor). To display or hide the status bar, use the Status Bar command on the Options 
menu.

Status bar information

Example Description
Ln 1 Current line number is 1.
Col 2 Current column is 2.
0x41, 65 ASCII code of the character at current cursor position (hexadecimal and 

decimal).
Lines 10 The number of lines in document.
Modified Changes in current document are not saved.
Insert Insert mode is active
UNIX Document will be saved in UNIX text format.



Scroll bars
GWD Text Editor has a horizontal and a vertical scroll bar that are used for moving vertically
and horizontally through a document with a mouse. Scroll bars are located at the right and 
bottom edges of the document window. The scroll boxes inside the scroll bars indicate your 
vertical and horizontal location in the document. You can use the mouse to scroll to other 
parts of the document.



Title bar

The title bar is located along the top of a window. It contains the name of the application 
and document.
To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.



Selection bar
Selection bar is the unmarked column along the left edge of the document window that you
can use to select large areas of text.

To select Do this with the mouse
One line Click the left button once.
Multiple lines Hold down the left button and drag.
One paragraph Double-click the left button.
An entire document Hold down the CTRL key, and then click the left button.



Menu bar
Located below the title bar, along the top of the application window; contains GWD Text 
Editor commands.
See also

Menu Commands



Text area
The area in which the text appears in your document.




